Home
Reply
Visitor
Posts: 4
0

Linnking Catia V5 for R20 works but R22 fails

Hi

 

I have happily linked in catiav5 R19 and R20SP2 into out application (64 bit windows VS2005).

But I have recently had the need to migrate to R22SP2 and can't get it to work

 

This seems to work really well for everything besides Catia5, so proe catia4 etc are working fine.

 

With catia5 however  I'm getting the following:

 

 Waring: CATIAV5 Environment is not set correctly.

 Warning : SPAXCATIAV5Base library not loaded.

 Warning : SPAXEnvironment library not loaded. (several times)

 

and then simply a translation failure when trying to convert.

 

Would someone have any suggestions on what I'm doing wrong?

Yes, I have checked the trouble shooting guides ......

 

If I point X3DT and A3DT to the R19 or R20 directories it all works perfectly

without having to do anything with setcatenv etc. Point them to the R22 directories

and I get the errors above.

 

Also setcatenv does not even run on my machine for the R22 directory

 

Please, this is driving me nuts ! Any help is appreciated.

 

Highlighted
Spatial Employee
Posts: 6
0

Re: Linnking Catia V5 for R20 works but R22 fails

Hi

 

You may need system update! In R22 release note, we have mention that VS C++ 2008 is needed.

 

Here is the docl link: http://doc.spatial.com/index.php/InterOp:Release_Notes/R22#Platform_Changes

 

Let me know this works,