Home
Reply
Highlighted
Contributor
Posts: 21
0
Accepted Solution

R20 64 bit

Hi

 

We are having issues with 64 bit (32 bit is fine) when

migrating to R20 from R19 sp1.

 

This issue is that going into V5 (reading is okay) the

translation from our own component doesnt 'fire up'

 

By that It appears not to load the component DLL's for the

rep's -- BREP assembly etc.

 

I have tried SPAXLogLevel=debug, but there was no more output

in the log

 

any ideas how I can bebug this OR what might be wrong ??

 

I double checked by build etc,

 

Super Contributor
Posts: 236
0

Re: R20 64 bit

Hello robc,

 

As this is an CSDK issue I believe this issue is best handled via support. Please create and incident so that we can investigate this further. Please include the log file for 32 bit and the CSDK implemenation to investigate this further. Is it only the V5 writer that is failing?

 

Regards,

Yogesh

Spatial Employee
Posts: 48
0

Re: R20 64 bit

Hello robc,

 

I saw the message string ' "GCO_R" is not a Spatial licensed component ' in the attached text file. It indicates that the licensing mechanism on 64 bit is failing.

 

Can you check if there is "anything" that you have changed as far as licensing goes ?

 

Because this check is done at the very beginning, that is the reason why the DLLs are not even loaded.

 

-shailesh

Spatial Moderator
Posts: 140
0

Re: R20 64 bit

Perhaps too basic a question, but are you sure you're not mixing platforms?  We did add VS2008 64-bit in R20 (in addiiton to the VS2005 we had in R19), so it's possible for one to mismatch VS2008 IOP binaries with your VS2005 build if you downloaded the wrong package by mistake.

Contributor
Posts: 21
0

Re: R20 64 bit

Thanks for all the feedback - problem solved.

 

It was a compile directive in our code which selected between R18 and R19

API calls in our SPAXGcoDocument, this was forgotten and so R19 onwards

functions line 'DoLoad' were missing.

 

The net affect is tha the converter completes okay, but does nothing.

 

Be nice if these things could be trapped and logged somehow.

 

But all is well again.

 

Thanks