Posts: 5

R23 setcatenv error

We include a CatiaV5 translator package in our Windows product. As part of our product installation we run 'setcatenv -e <our_env_name> -p <our_lib3dx_path>' and put <our_lib3dx_pah>/blah/code/bin on the system path to make things work. If your machine has seen one of our installations before this seems to work without trouble. However, if your machine has never seen one of our installations, we see


ERROR: Unable to save the environment file in "".


in the installer's log.


If you let the installer finish and then just try our translator, it doesn't work. But if you manually re-run the setcatenv command, the setcatenv command works and our translator starts working.


I tried to reproduce the fault manually by putting just the lib3dx bundle on the clean machine and running setcatenv. It works fine if that's all you do, and it fails with the above error if you set the lib3dx bin path first. So we tried reordering things in our installer to update the system path after running setcatenv, but in the installer context this doesn't help.


Has anyone had similar trouble and if so were you able to fix it?




Regular Contributor
Posts: 41

Re: R23 setcatenv error


First reasnon is the different environment in manula mode and at the installation mode

Second resaon is space symbols at the file path. You can try to enclose path to lib3dx and to toolkit in quotation mark.